FC2ブログ

続きを読む

【電気通信主任技術者】対策

 ■1. 受験科目

 【1. 電気通信システム】
 【2. 専門能力(データ通信)】
 【3. 伝送交換設備及び設備管理】
 【4. 法規】


■2. 難易度的
 2>3>>>>>>>1>4


■3. 問題の出題傾向・対策
 【出題傾向】
  (1) 30%は過去問から出題

  (2) 下記3科目は、重複している問題が多い。

    【1. 電気通信システム】
    【2. 専門能力(データ通信)】
    【3. 伝送交換設備及び設備管理】


 【対策】
  (1) 点の取り方
    30%: 過去問
    20%: 実力
    10%: 運

  (2) 受験の方法

    ① 1回目の受験:
      【1. 電気通信システム】
      【2. 専門能力(データ通信)】
      【3. 伝送交換設備及び設備管理】

    ② 2回目の受験
      【4. 法規】
      他、落とした科目


  (3) 勉強方法

    ① 過去問6年分
      ⇒参考書で解説読む。
       余裕が出てきたら、わからないところや単語をネットで検索。

■4. 勉強サイト
http://www8.plala.or.jp/ap2/shinraisei/shinraisei3.html#shinraido
http://susumeweb.com/archives/602
http://denki9.exblog.jp/i3/


■参考書
日本理工出版会


 ただ、法規と電気通信システムは丸暗記でいけるけど、残り2つは難しい

科目合格の有効期限が3年だから、難しい2科目を先に勉強したらいいと思う


電気通信主任技術者試験全問題解答集〈1〉共通編〈13‐14年版〉電気通信主任技術者試験全問題解答集〈1〉共通編〈13‐14年版〉
(2013/05)
電気通信主任技術者試験研究会

商品詳細を見る


続きを読む

【IT/ビジネスメモ】IT情報

メモ記載日概要備考
2012/10/28(日Buzz Finder (口コミ集計サービス)月額10万~
2012/5/27(日)イーサネット・ファブリック
(データセンターやキャリア・コア・ネットワークにおいて求められる性能や運用性を向上するための新しいEthernetネットワーキング技術)
2012/4/1(日)技適(技術基準適合証明)
2012/3/4(日)
2012/2/26(日)モバイルアプリの安全性評価技術、Trend Microが開発
2012/2/26(日)TD-LTEは通信効率の低下にもなる。
2012/1/29(水)NWのトラフィックが少ないときに
イーサネット機器の消費電力を減らす機能。
2012/1/22(日)Google、Androidアプリ開発を学べる「Android Design」を立ち上げ 同社は昨年12月、Androidアプリ
開発者向けトレーニングサイトも開設。
2012/1/22(日)Android公式マーケットにまた不正アプリ、ユーザーをだます手口が巧妙化Symantecは同社のウイルス対策
ソフトで、この不正なアプリを検出
できるようにするとのこと。
2011/12/30(金)用料金は90日間で計25時間が50ドル。
5時間延長するごとに追加で20ドルが
必要になる。
2011/12/30(金)次世代LTE(LTE-Advanced)2014年実用化
2011/12/30(金)Windows 8(次期Windows OS)仮想化ソフト「Hyper-V」を搭載
2011/12/30(金)次世代無線LAN規格(IEEE802.11ac)標準化の完了時期も2013年6月頃に

なると見られている。
2011/12/30(金)通話履歴もメールも残さないAndroidアプリ、NTTソフトが開発
 
インターネット歴史年表

続きを読む

【LPIC_101試験】2. インストール関連

■1. ハードディスク設計

 【論理ボリューム】
  (1) 作成手順
     ① 物理ボリューム作成(PV)の作成: pvcreateコマンド
     ② ボリュームグループ(VG)の作成: vgcreateコマンド
     ③ 論理ボリューム(LV)の作成: lvcreateコマンド




■2. ブートマネージャ



■3. 共有ライブラリ



■4. Debianパッケージ

  dpkgコマンドオプション】
オプションコマンドフルスペル機能説明
-E
同じverがインスト済なら、インストしない
-GGrade?新verがインスト済なら、インストしない
-RRecursive?再帰的に実行


アクションコマンドフルスペル機能説明
-i [ パッケージ名 ] --installインスト
-r  [ パッケージ名 ] --remove設定ファイルを残し、アンインスト
-P [ パッケージ名 ] --purge(掃除)設定ファイルもろともアンインスト
-l [ 検索パターン名 ] --listインスト済のパッケージ検索表示
-L [ 検索パターン名 ] --listfiles該当パッケージからインストしたファイルのみ表示
-s  [ パッケージ名 ] --statusインスト済のパッケージ詳細情報表示
 -S --search該当ファイルがどのパッケージからのインストかを検索表示
 -C--auditインストが中断されているパッケージのみ表示


 apt-getコマンド】
 情報DBを使用し、パッケージの依存関係を調整しつつ、パッケージインスト・アンインストをやってくれる
オプションコマンド機能説明
install  [ パッケージ名 ]パッケージのインスト・アップグレード
remove   [ パッケージ名 ]パッケージのインスト
upgradeインスト済の全てのパッケージのアップグレード
dest-upgradeディストリビューションを最新にアップグレード
updateパッケージのDBを最新にする
clean過去に取得したパッケージのファイル削除


 【apt-cacheコマンド】
オプションコマンド機能説明
search [キーワード]全パッケージに対し、キーワード検索
show  [ パッケージ名 ]パッケージ情報表示
 showpkg  [ パッケージ名 ]該当パッケージに対し、被依存関係を含んだ情報表示
depends  [ パッケージ名 ]依存しているパッケージ表示



■5. RPMS・YUMパッケージ

 【yumコマンド
オプションコマンド機能説明
install  [ パッケージ名 ]インスト
uodate  [ パッケージ名 ]アップデート
remove  [ パッケージ名 ]アンインスト
info  [ パッケージ名 ]詳細情報表示
list  [ パッケージ名 ]情報一覧表示(Ver、インストールの有無)
search  [ キーワード ]全パッケージに対し、キーワード検索
check-update  [ パッケージ名 ]アップデートできるパッケージ表示
grouplistパッケージグループの表示
groupinstall  [ グループ名 ]パッケージグループのインスト


 rpmコマンド
  (1)検索コマンド

オプションコマンドコマンドのフルスペル機能説明
-q  [ パッケージ名 ] --queryインストされているか検索
-V  [ パッケージ名 ] --verifyパッケージ検査
(-a と --nomd5 コマンドのみ併用可能)
併用可能なオプション
コマンド
コマンドのフルスペル 機能説明
-a --allインスト済の全パッケージ表示
-l --list指定パッケージ内のファイル表示
 -i --info指定パッケージの詳細情報表示
 -f  [[ファイル名 ]--file指定ファイルがどのパッケージからインストされたか
検索表示
 -p --packageパッケージファイルだけから検索
 --changelog
指定パッケージの変更履歴表示
 -c--configfiles設定ファイル表示
 --nomd5
MD5のファイル改ざんを検査無し


 (2) インストールコマンド
オプションコマンドコマンドフルスペル機能説明
 -i  [ パッケージ名 ] --installインスト
 -U  [ パッケージ名 ] --upgradeアップグレード。
未インストのとき、インストする
 -F  [ パッケージ名 ] --freshenアップグレード。
未インストのとき、インストしない
 -e --eraseアンインスト
併用可能なコマンド
オプション
コマンドフルスペル機能説明
 -v various?詳細情報表示
 -h--hash進行状況表示
 --test
 実行せず、テストだけ実施
 --nodeps
依存関係無視




続きを読む

【LPIC_101試験】1. システムアーキテクチャ

■ハードウェアの構成・設定

 【デバイス情報コマンド】
  ※「/proc」ディレクトリ配下のファイルでも確認可能 (
ディレクトリ構造参照)

   ・lspci: PCI情報確認
   ・lsmod: ロード中のカーネルモジュール情報確認
   ・lsusb: USBデバイス情報確認

  ・modprobe: 依存関係を考慮し、カーネルモジュールをロードもしくはアンロード
------------------------------------------------------------
 【USB関連】
  (1) USBデバイスクラス
USBデバイスクラスデバイス
ACM Communication Device Classモデム、TA
Audio Classマイク、スピーカー
HID (Human Interface Device)キーボード、マウス
Mass Strage ClassUSBメモリHDD

 (2) USBコントローラー関連
コントローラ規格USBモジュール
(カーネル2.4)
USBモジュール
(カーネル2.6)
UHCIUSB1.1usb-uhciuhci_hcd
OHCIUSB1.1usb-ohciohci_hcd
EHCIUSB2.0サポート無ehci_hcd



■システム起動

 【1. 起動順序(一般的なLinux)】
   (1)BIOS: HDDなどに関し最低限の認識MBRをロードし、ブートローダに制御を渡す
   (2)ブートローダ: カーネルをロードし、カーネルに制御を渡す
   (3)カーネル: 高度なHW認識し、マウントなど色々な初期化を実行
   (4)init: アプリレベルの初期化(プロセスIDは必ず「1」)
  





■ランレベル・システムシャットダウン

続きを読む

ブログメモ

■分数/累乗をHTMLで表現
 ▼分数のHTML変換ツール
 ▼無理矢理数式

表の作り方

折りたたみ方法

 </span><span style="font-family: 'MS Pゴシック'; "><table border="" bgcolor="#FFFFFF" bordercolor="#ffffff" cellpadding="10" cellspacing="2" style="color:#fffffff;"><tbody><tr><td bgcolor="#FFFFFF" style="text-align: left; "><span style="font-size: medium; "><span style="font-family: 'MS Pゴシック'; "><u><strong>■No. タイトル</strong></u></span></span></td>
</tr><tr class="js_close">
<td bgcolor="#ffffff">


<<<折りたたむ内容記載>>>
</tr></table>

続きを読む

続きを読む

CCNP TSHOOT(642-832J)

  (1) CCNP TSHOOT(642-832J)
    1. 出題形式・出題される問題について
    2. トラブルチケットの解き方・考え方
    3. 試験で使用するコマンド
    4. Switch基礎知識 (ポートセキュリティVLANEtherChannel
    5. Route基礎知識 (DHCPHSRPEIGRPOSPFBGP再配送NATACL
    6. IPv6
    NWパフォーマンス監視
    ※参考サイト

【Facebook】情報整理

■1. Facebook とは、世界最大のSNS
 
メリットデメリット
全世界ユーザ9億人、日本1000万人個人情報流出のリスク
情報拡散性に優れている使い方が分かりづらい
ターゲッティングが細かく可能
無料
機能PC版Facebookスマホ版Facebook
広告機能有り無し
友達の「いいね!」
に対する操作
ページ飛ばず可能「いいね!」されたページに
一度飛ぶ必要がある
Facebook
サブページ表示
全て表示可能「ウォール」「基本データ」「写真」しか表示されない。
Facebookページ
アプリ利用
利用可能利用可能
(FacebookのPCサイトに移動すると閲覧可能。
使用できるかは不明)
「シェア」機能有り無し

■2. Facebookページでの商品販売

  1. にも記載した通り、PC版Facebookとスマホ版Facebookはでは機能差分がある。
  スマホ版では、アプリを使用したFacebookサブページが見れないので、
  スマホ版では、商品購入不可と思われる。

  また、PC版Facebookの商品販売ページを見ると、一応、Facebookページだけで、商品をカートに入れ、
  購入までできるところはある。
  でも、ほとんどの企業のFacebook商品販売ページは、自社HPの商品販売ページへリンクで飛ばしている。
  理由は2つ?

  (1) スマホ版Facebookでは、機能制約により商品購入できない
  (2) 「Facebook版での商品管理」と「自社HPの商品販売ページの在庫管理」の連携が難しい

■3. Facebookページコンサル

  【Facebookコンサル会社】
  
株式会社ストックス(構築、運用、効果測定を利用したレポートもあり)

■参考URL

【Facebook Social Apps】
Hivelo Social Apps


【効果測定】
効果測定サービス

続きを読む

名言集

■名言集
Noジャンル媒体名言情報元
1人生論映画何もかも神に頼る者は、自分の中にあるパワーに気づいていないんだ。
奇跡がみたいのなら、自分で起こせ。
ブルース・オールマイティ
2神に「忍耐」を望めば、「忍耐」をくれるのか、それとも「忍耐強くなるチャンス」をくれるのか。
「勇気」を望めば、「勇気」をくれるのか、それとも「勇気を出すチャンス」をくれるのか。
エバン・オールマイティ
3イエスは、人生のパスワード。イエスマン
4諦めるな、最後の1秒まで。炎のメモリアル
5一日一日を運命の日と思え。最後の恋のはじめ方
6人はなぜ落ちるのか。這い上がるためだ。アレキサンダー
7絶対的窮地に追い詰められながらも諦めることを知らない男ミッション:インポッシブル/
ゴースト・プロトコル
8つらいと思っていても、どうしようもない。それよりも、今、自分は何をすべきか考えることだ。ロード・オブ・ザ・リング
~旅の仲間~
91歩先だけじゃ足りない。(相手の)3歩先を読め。特攻野郎Aチーム
10TVドラマ神は乗り越えられる試練しか与えない。JIN(仁)
11最下位には、最下位の戦い方がある。崖っぷちのエリー
12本当に手は尽くしたのか?
13より良い道を探し続けることが、最高の人生だ。ソクラテスの人事
14最初から、不可能なことなんて無い。PRICELESS(プライスレス)
15書籍君が諦めるまで、神様は諦めない。「3分」で気持ちの整理ができた。
(中谷彰宏)
16成績1位より、練習量1位を。なぜあの人は壁を突破できるのか
(中谷彰宏)
17KO負けになってもいい。一発だけでも、強烈なパンチをお見舞いすることだ。昨日の自分に別れを告げる
(中谷彰宏)
18毎日、自己新記録を更新しよう。明日がワクワクする50の方法
(中谷彰宏)
19今サボると、一生サボることになる。昨日と違う自分になる「学習力」
(中谷彰宏)
20遅い正解より、速い「ほぼ正解」。
21今ここで諦めたら、諦めることがクセになってしまう。中谷彰宏 名言集
(中谷彰宏)
22頑張れより、頑張ってるね。なぜあの人は、人の心が読めるのか
(中谷彰宏)
23意識化→無意識化のプロセスこそが、成功だ。※メルマガより
(石井貴士)
24仕事TVドラマ大手企業が1年かかるところを、僕らは1日でやってみせる。それも、正確に。リッチマン・プアウーマン
25新しいことをやると、必ず非難される。でも、全てはそこから始まるんだ。
26打つ手なんか、いくらでもある。
27いつか必ず、君を喜ばせる。
28期限は3日?僕をなんだと思っている。2日で出来る。
29書籍やることが多いのと、忙しいのは違う。忙しいのは決断が遅いだけ。スピード決断術
(中谷彰宏)
30スピードの新記録を出すと、それが普通になる。大人のスピード思考法
(中谷彰宏)
31仕事も戦争も基本は同じ。同時に多発させる。なぜあの人は仕事が速いのか
(中谷彰宏)
32構想力は、「シリーズ化力」。一流の常識を破る「超一流」の構想術
(中谷彰宏)
33スピードは、行動の数に比例して速くなる。スピード自己実現(中谷彰宏)
34その他-「不可能」の反対語は「挑戦」だ。(メジャーリーク:ジャッキー・ロビンソン)五階の社窓から
35強く望めば、何でも叶う。(ピーター・パン)
36自分が責任者であるという態度で接する。(神様からの一言)
37逆境のなかで鍛えられた人間だけが、逆境を突破していける。(ロバート・シュラー)
38①生きることは学ぶこと。学ぶことは変わること。
39②お客様が先生。仕事が教材。現場が教室。
40③全員経営。オンリーワン・ナンバーワン。
41(関ヶ原製作所)
42つかみ1秒。あと、楽勝!(伸先生)
43人間にとって、転んだことは恥ずかしいことではない。
44起き上がれないことが恥ずかしいことだ。(三浦綾子)
45勇敢な男は、自分のことは最後に考えるものである。(シラー)
46人生の意味は、自分の中にはない。(ヴィクトール・エミール・フランクル)
47訓練に裏付けられていない直観は、デタラメである。(池谷裕二)
48⇒直観は学習(努力の賜物)
49夢を敵える4つのC
①好奇心(Curiosity)
②自信(Confidence)
③勇気(Courage)
④継続(Constancy)

続きを読む

【ホームNW】レオネット関連

■レオネット環境で、PS3・nasneを接続する方法
 レオネットの再認証を無くす方法
 レオネット認証できないnasneをインターネット接続させる方法
 ⇒ルータでレオネット認証させ、ルータ配下は、別NWとすることで、
      nasneをレオネット認証なしで、インターネット接続可能となる。
 


【参考URL】
 http://www.zqwoo.jp/sak_bfqa/show_c/110457#2
 http://vertex.air-nifty.com/blog/2008/02/post_dfc9.html
 http://www.leo-net.jp/leoweb_e/guide/guide04_02.html
 http://pc11.2ch.net/test/read.cgi/isp/1253371386/198





【CCNP-TSHOOT】ポートセキュリティ

ポートセキュリティデフォルト設定】

 ・無効
 ・セキュリティ違反時:shutdown
 ・IFに登録可能なMACアドレス数:1

===================================================

 
Maximum MAC Addresses: 登録可能なMACアドレス数
Total MAC Addresses : 登録されているMACアドレス数
Configured MAC Addresses : 手動設定されたMACアドレス数
Sticky MAC Addresses :Stickyラーニング学習したMACアドレス数
Last Source Address: このポートで最後に受信した送信元MACアドレス
Security Violation Count …:セキュリティ違反回数

ciscoコマンドメモ

■基礎コマンド
 出力行数の制限解除: terminal length 0
 ログ確認: show logging、show running-config

【CCNP-TSHOOT】BGP

BGP設定

 (1) router bgp {AS番号}←BGP有効化(ここのAS番号は自ルータ所属のAS番号)
 (2) "network {NWアドレス} mask {マスク}←通知する経路情報指定
 (3) "neighbor {IPアドレス} remote-as {AS番号} ←ペアとする相手ルータのAS番号


 【bgp状態確認】
 show ip bgp summary

 【プライベートAS】
 AS番号0~65535の中で、64512~65534の範囲のこと

【CCNP-TSHOOT】EtherChannel

■EtherChannel

 【EtherChannelモードと組み合わせ】



モード on auto
(PAgP)
desirable
 (PAgP)
passive
(LACP)
active
(LACP)
on××××
auto
(PAgP)
××××
desirable
 (PAgP)
×××
passive
(LACP)
××××
active
(LACP)
×××


 【EhterChannel組む時の条件】

 (1)メディアタイプ
 (2)速度・デュプレックス
 (3)イッチポートの種類(アクセスポート/トランクポート/L3ポート)
 (4)VLAN(アクセスポート時)
 (5)ネイティブVLAN・搬送するVLAN範囲(トランクポート時)
 (6)トランクモード(トランクポート時)

【CCNP-TSHOOT】VLAN

■VLAN

 VTP( VLAN Trunking Protocol )】
 NW全体において、VLAN設定の一貫性を維持するためのcisco独自プロトコルである。

 (1) VTPの動作モード3種

   ① Serverモード: VLAN追加・削除・変更「可能
   ② Clientモード: VLAN追加・削除・変更「不可」、
                      VLAN設定等をVTPドメイン内のSWにアドバタイズ可能
   ③  Transparent モード: VLAN追加・削除・変更「可能」VTPドメインと無関係なので、同期せず、
                       アドバタイズは透過して他のSWに転送する


===================================================
 【VLAN基本設定】

 (config)#interface {IF}
 (config-if)#switchport mode access
 (config-if)#switchport access vlan (VLAN番号)

【CCNP-TSHOOT】ACL

■ACL関連

 【ルートマップ設定】

  (config)#route-map {マップ名} [permit or deny] [シーケンス番号]
  (config-router-map)#match {条件1}
  (config-router-map)#match {条件2} ←両方満たした場合、setを適用
            ※両方満たさない場合は、暗黙のdenyにより、再配送しない
  (config-router-map)#set {アクション}

  マップ名: 任意名
  permit: 条件一致時に再配送する。
  deny: 条件一致時に再配送しない。
  シーケンス番号: ルートマップの処理順番(早い番号から処理)
  EIGRPのシードメトリック: 帯域幅、遅延、信頼性、負荷、MTU

------------------------------------------------------------

 【標準ACL】
  Router(config)#ip access-list standard (名前 | 番号)

 拡張ACL
 Router(config)#ip access-list extended (名前 | 番号)

【CCNP-TSHOOT】NAT

■NAT関連

 【ダイナミックNAT設定】

  (1)IF設定
    (config)#int 外側IF
    (config-if)#ip nat outside
    (config-if)#int 内側IF
    (config-if)#ip nat inside


  (2)グローバルアドレス範囲設定

   (config)#ip nat pool {プール名} {グローバル開始IPアドレス} {グローバル終了IPアドレス}
        {netmask or prefix-length} {マスク}


  (3)ローカルアドレスとアドレス範囲の紐付け

    (config)#ip nat inside source list {ACL番号} pool {プール名} [overload]
    

  (4) 標準IP-ACLでローカルアドレス設定

     (config)#access-list {ACL番号} permit {ローカルアドレス} [ワイルドカード]


  ※overload:多重定義(NAPT)

【CCNP-TSHOOT】再配送

■再配送

 【EIGRPからOSPFへ再配送の設定方法】

 Router(config)#router ospf {プロセスID} ←再配送したいプロトコルを入れる
 Router(config-router)#redistribute eigrp {AS番号} [metric {値}] [metric-type {タイプ}] [tag {タグ}] [route-map {マップ名}] [subnets] 


 metric: シードメトリック指定。省略時はデフォルトの20。
 metric-type: OSPFの外部リンクタイプ1or2を指定。省略時はデフォルトの2。
 tag: 0~4294967295のタグ値を付加
 route-map: ルートマップ使用
 subnets: サブネット化されたルートを再配送。省略時はサブネット化していない経路のみ再配送。
      つまり、クラスレスの再配送時に必須。


  ※コンフィグ
  router ospf 1 ←再配送したいプロトコル
  redistribute eigrp 1 ←着信したプロトコル
  network 192.168.1.0 0.0.0.3 area 0
  default-metric 64 ←再配送したいシードメトリック


------------------------------------------------------------
 【OSPFからEIGRPへ再配送の設定方法】


 Router(config)#router eigrp {プロセスID} ←再配送したいプロトコルを入れる
 Router(config-router)#redistribute ospf {AS番号} [metric {値}] [metric-type {タイプ}] [tag {タグ}] [route-map {マップ名}] [subnets]


  ※コンフィグ
  router eigrp 1 ←再配送したいプロトコル
  redistribute ospf 1 ←着信したプロトコル
  network 192.168.2.0 0.0.0.255
  default-metric 56 100 255 1 1500 ←再配送したいシードメトリック。EIGRPへ再配送する場合、デフォルトシードメトリックは無限大なので指定必須。

【CCNP-TSHOOT】OSPF

OSPF

 【大前提】
 エリア間通信はarea0(バックボーンエリア)を通る決まりがあるため、各エリアのABRはarea0との接続は必須

 【OSPF設定】
  (config)#router ospf {プロセスID}
  (config-router)#network {NWアドレス} {ワイルドカードマスク} area {area-ID}


------------------------------------------------------------
 【隣接関係確立条件】

  下記が一致していること 

  (1) Hello/Deadの間隔
  (2) エリアID
  (3) 認証パスワード
  (4) サブネットマスク
  (5) スタブエリアフラグ

------------------------------------------------------------
 【OSPFインターフェース認証(平文)】

  (config-if)#ip ospf authentication
  (config-if)#ip ospf authentication-key [password]

------------------------------------------------------------
 【OSPFエリア認証(MD5)】
  (config)#router ospf {プロセスID}
  (config-router)#area {area-ID} authenticationmessage-digest
  (config-router)#exit
  (config)#interface {IF}
  (config-if)#ip ospf message-digest-key [Key-ID] md5 [password]

【CCNP-TSHOOT】EIGRP

■EIGRP


 EIGRPの基本設定
  (config)#router eigrp {AS番号}
  (config-router)#network {NWアドレス} [ワイルドカードマスク]

 【EIGRPメトリック設定】
  (config-router)# metric weights [TOS] [K1 K2 K3 K4 K5]

  ※KデフォルトはK1=K3=1、K2=K4=K5=0 (1 0 1 0 0)
   コンフィグにK値の記載がなければデフォルト。
   よって、隣接関係の片側ルータにK値があえて入っているとデフォルトから変更されており、
   それにより、隣接関係が確立できていない可能性がある。


------------------------------------------------------------
 【隣接関係確立条件】
 
  下記が一致していること

  (1) AS番号
  (2) K値 ←メトリック計算に使用する値

------------------------------------------------------------
 【MD5認証使用時のEIGRPネイバー構築条件】

  パスワード(key-string)とキーIDが一致すること

------------------------------------------------------------
 フィージブルサクセサ(バックアップルート)】

 (1) 特徴

   ① サクセサのFDよりも小さなADを持ったルートがフィージブルサクセサになる
   ② サクセサがダウン時は、フィージブルサクセサがサクセサになる。
   ③ フィージブルサクセサ(バックアップルート)を使用し通信もする場合もある

 (2)FDとAD

  FD( Feasible Distance ):自ルータから宛先NWまでの合計メトリック
  AD (Advertised Distance) :ネイバールータから宛先NWまでの合計メトリック

------------------------------------------------------------
 【その他必要知識】
 passive-interface : IFにこの設定が入っていると、ルート情報は更新するが、パケットを送信しなくなる
 
passive-interface default ←全IFをパッシブ・インタフェースにする
 no passive-interface fa1/0 ←でも、fa1/0だけはパッシブ・インタフェースにしない

【CCNP-TSHOOT】HSRP

■HSRP(Hot Standby Routing Protocol)

 ・プライオリティが高い方がアクティブになる
 ・フェールオーバーすると、DSWのプライオリティ値が減少する
 ・プライオリティが減少した原因を解消すると、プライオリティ値は元に戻る


 【stanbyからactiveに切り替わらない原因】

 (1) Preemptionがenabledでない
 (2) プライオリティ値が減少していて、プライオリティ値が元に戻っていない。

    ① トラッキングが働いている可能性あり
      ・IFダウンしていないか確認
      ・ルーティングが消えていないか確認

    ② トラッキングが解決しても、プライオリティ値が元に戻らないこともある

      standby 10 track 1 decrement 30 ←トラッキング(track1が何と紐づいているかsh runで確認)
      threshold metric up 1 down 2 ← 「メトリックが1以下なら生、2以上なら死」と判定

【CCNP-TSHOOT】DHCP

DHCP
 no service dhcp:DHCPサービス無効化

 【DHCPサーバ設定】

  (config)#ip dhcp pool {プール名} ←プールアドレス設定
  (dhcp-config)#network {NWアドレス/サブネットマスク} ←クライアントに割り振るIPアドレスの範囲設定
  (dhcp-config)#lease {日数} ←貸出期間設定(デフォルト1日)
  (dhcp-config)#dns-server {DNSサーバIP①} [DNSサーバI②] ← DNSサーバ設定(最大8個)
  (dhcp-config)#default-router {DG-IP①} [DG-IP②]  ←DG設定(最大8個)
  (dhcp-config)#netbios-name-server {WINSサーバIP①} [WINSサーバIP②]  ←WINSサーバ設定(最大8個)
  (dhcp-config)#import all ←統合しているDHCPサーバからパラメータ取得
  (config)#ip dhcp excluded-address {開始IP} [終了IP] ←割り当て除外設定


  【DHCPリレーエージェント設定】
  (config-if)#ip helper-address (DHCPアドレス}

Windowsコマンドメモ

≪windowsコマンドメモ≫



■dirコマンド
 cd /d y:
 dir rdp* /s
 dir /ad /s
■trace
 tracert -w
■ショートカットコマンド
 ・「ctrl」+「;」⇒日付
 ・「ctrl」+「:」⇒時間
 ・「ctrl」+「r」⇒左を右にコピー
 ・「ctrl」+「d」⇒上を下にコピー
 ・「ctrl」+「5」⇒取り消し線つける/外す

続きを読む

【CCNP-TSHOOT】IPv6

OSPFv3: IPv6に対応しているOSPFバージョン

 【OSPFのコンフィグ】

 ipv6 ospf (AS番号) area (エリア番号) ←IFに設定する

 
 RIPng( RIP Next Generation )
  IPv6対応のRIP
 
 【IPv6有効化】
 ipv6 unicast-routing

 【IPv6ルーティング確認】
 show ipv6 route

 IPv6(オートコンフィグレーション)
 IPアドレスの自動設定(ルータが先頭64ビット提供、残り64ビットはクライアントMACを使用)

【ciscoコマンド】show port-security

show port-security (ポートセキュリティの設定確認)
   ・IFのセキュアMAC アドレス最大許容数
   ・IFのセキュアMAC アドレス数
   ・セキュリティ違反数
   ・セキュリティ違反時のモード

【CCNP-TSHOOT】NWパフォーマンス監視

■NWメンテナンスモデル

 【シスコライフサイクルサービス(PPDIOO)】

  P: 準備(Prepare)
  P: 計画(Plan)
  D: 設計(Design)
  I: 導入(Implement)
  O: 運用(Operate)
  O: 最適化(Optimize)


------------------------------------------------------------
 【FCAPS(エフキャップス)】

 ISOによって定義されているモデル

 F: 障害管理(Fault management)
 C: 設定管理(Configuration management)
 A: 課金管理(Accounting management)
 P: 性能管理(Performance management)
 S: セキュリティ管理(Security management)


------------------------------------------------------------
 【ITIL(Information Technology Infrastructure Library)】

 ITサービスに関するベストプラクティス集。


------------------------------------------------------------
 【TMN(Telecommunications Management Network)】

 電気通信NW対象のモデル


===================================================
■ログレベル

 レベル0: 緊急(Emergencies)
 レベル1: 警報(Alert)
 レベル2: 重大(Critical)
 レベル3: エラー(Error)
 レベル4: 警告(Warning)
 レベル5: 通知(Notification)
 レベル6: 情報(Informational)
 レベル7: デバッグ(Debugging)

===================================================
■トラシュー方式

 【トップダウン方式】
  上位層から調べる

 【ボトムアップ方式】
  下位層から調べる

 【分割統治方式】
  中間層から調べる
 
 【トラフィックパス追跡方式】
  トラフィックのパスを追跡して調べる

 【コンポーネント交換方式】
  被疑機器を交換して調べる

 【設定比較方式】
  正常設定と比較して調べる


===================================================

■SW・Routerのサーバ機能設定

 【webサーバへ接続する際の、ユーザID・パスワード変更コマンド】
  (config)#ip http client username
  (config)#ip http client password

 【FTPサーバへ接続する際の、ユーザID・パスワード変更コマンド】
  (config)#ip ftp username
  (config)#ip ftp password

 【NTPサーバにて、特定のNTPサーバを優先したいときに使用するコマンド】
  (config)#ntp server {NTP-IPアドレス} prefer

※prefer:~の方を選ぶ

【ciscoコマンド】show ip bgp summary

■show ip bgp summary


 local AS number: 本ルータの所属AS番号
 Neighbor: BGPピアのIPアドレス
 V: BGPピア間で使用しているBGPバージョン
 AS: BGPピアの所属AS番号
 State: BGPピアとの状態(空欄はEstablished(ピア関係確立)を意味する)


 【BGPステータス種類】

  (1)Idle: 初期状態。(TCP接続を開始⇒ Connect状態)

  (2)Connect: ピアとのTCP接続開始から完了まで。
    (OPENメッセージを送り Open Sent状態)

  (3)Active: ピアとのTCP接続失敗、TCP接続リトライから完了まで。
     (OPENメッセージを送り Open Sent状態)

  (4)Open Sent: ピアからのOPENメッセージ待ち状態。
     (メッセージを受け取ったら、 Keepaliveを送り Open Confirm状態)

  (5)Open Confirm: ピアからのKeepalive待ち状態。
    (Keepalive受け取ったら Established状態)

  (6)Established: BGPピア確立


===================================================

■メモ
 iBGP: 同じAS番号の場合 (i: internal)
 eBGP: 異なるAS番号の場合 (e: external)

【CCNP-TSHOOT】参考サイト

 【1. 試験のデモ映像】
http://video.excite.co.jp/player/?id=cd9eaf4faeb83e52&title=ExSim-Max+for+Cisco+T-SHOOT+642-832+Demo
  
------------------------------------------------------------
 【2. 試験デモ、チュートリアル】
  https://learningnetwork.cisco.com/docs/DOC-6738
  http://www.cisco.com/web/learning/le3/le2/le37/le10/tshoot_demo.html

------------------------------------------------------------
 【3. トラブルチケットで使用されているトポロジ】
  https://learningnetwork.cisco.com/servlet/JiveServlet/downloadBody/6741-102-1-23100/TSHOOT%20Exam%20Topology.pdf

------------------------------------------------------------
 【4. GNS3を使ったシュミレーション問題のconfig例】
  http://learningnetwork.cisco.com/servlet/JiveServlet/download/81290-12300/TSHOOTbyGNS3.doc

------------------------------------------------------------
 【5. 勉強サイト】
 ・CCstudy Cisco試験応援サイト(CCNA,CCNP,CCIE)
  http://www.ccstudy.org/index.html

 ・@network Cisco・アライド実機で学ぶ
  http://atnetwork.info/

------------------------------------------------------------
 【6. 受験記】
  http://ping-t.com/modules/xfsection/article.php?articleid=3969
  http://ping-t.com/modules/xfsection/article.php?articleid=3927

  http://ping-t.com/modules/xfsection/article.php?articleid=3336

  http://ping-t.com/modules/xfsection/article.php?articleid=4351
  http://ping-t.com/modules/xfsection/article.php?articleid=4222
  http://ping-t.com/modules/xfsection/article.php?articleid=3439
  http://ping-t.com/modules/xfsection/article.php?articleid=3370
  http://ping-t.com/modules/xfsection/article.php?articleid=3346

------------------------------------------------------------
 【7. その他(英語サイト)】
  https://learningnetwork.cisco.com/groups/ccnp-study-group?view=discussions&start=0
  https://learningnetwork.cisco.com/message/81290#81290

【CCNP-TSHOOT】トラブルチケットの解き方・考え方

■0. 問題を解くための前提知識


※HSRPのDSW1がアクティブルータの場合

(1) PCがIPアドレスを取得する流れ

------------------------------------------------------------
【PC】(DHCPパケット送出)--->【ASW1】--->【DSW1(R4にDHCPリレー)】--->【R4】(DHCPパケット応答)

--->【DSW1】--->【ASW1】--->【PC】(IPアドレス取得)
------------------------------------------------------------



(2)IPアドレスを取得後のトラフィックフロー

------------------------------------------------------------
【PC1】--->【ASW1】--->【DSW1】--->【R4】--->【R3】--->【R2】--->【R1】--->【サーバ】
------------------------------------------------------------


上記フローより、【DSW2】と【ASW2】のコンフィグは特に確認せずともOKと推測できる。




===================================================

■1. PCがDHCPでIPアドレス取得して「いる」場合】(ipconfig)

(1) PCよりPingにて、どこまで疎通確認できるかを確認

    Ping実行は、ルーティング・ドメインの境界機器となる【DSW1】【R4】【R1】を対象とし、
    各機器の手前側と向こう側のIF宛てに実施する


(2) 被疑機器にて各コマンドを実行して事象原因を特定

    ※被疑機器でルーティングが無い場合、ルーティング追加することで解決
    ※被疑機器でルーティングある場合、ACL・NATフィルタなどを確認
    ※被疑機器でネイバーや再配布の設定も怪しい

   以下は、原因特定の事例


   ①【DSW1】が被疑機器の場合

    「show ip route」コマンドで「D EX(外部経路情報) 0.0.0.0」が存在するかを確認し、無い場合、
     【R4】とのEIGRPが確立していない(show ip eigrp neighbors)、もしくは、redistributeの設定が原因


   ②【R4】が被疑機器の場合
   
    「show ip route」コマンドで「O*IA 0.0.0.0」が存在するかを確認し、無い場合、
     【R3】とのOSPFが確立していない(show ip ospf neighbor)、もしくは、完全なNssaではないことが原因


   ③【R1】が被疑機器の場合

    「show ip route」コマンドで BGPに対する経路があるかを確認し、無い場合、
    【R5】とのBGP経路交換がしっかりできていない。
    そのため、【R1】のBGPコンフィグまたはACLの設定を確認。
    (隣接するBGPスピーカからのアップデートを妨げていないかなど)

    
===================================================
■2. PCがDHCPでIPアドレス取得して「いない」場合】(ipconfig)


(1)【ASW1】

   ① show ip int brief ⇒ Fa1/0/1がupしているか確認
   ② show port-security ⇒ 状態確認
   ③ show int trunk ⇒ Po13にVLAN 10が割り当てられているか確認

(2)【DSW1】

   ① show etherchannel summary ⇒ Po13がSUであるか確認
   ② show ip route ⇒ D*EX 0.0.0.0 が存在するか確認
   ③ show ip route ⇒ vlan10において、ip helper-addressはR4のIPアドレスであるかを確認

(3)【R4】

   DHCPにおいて「no service dhcp」の設定が入っていないことを確認
   クライアントに割り振るアドレスプールが正しいか確認



【CCNP-TSHOOT】★最強ノート

■1. 出題形式・出題される問題

 【1. 選択問題(1 or 2問)】

   ネットワークパフォーマンスの維持および監視



 【2. ドラッグアンドドロップ問題】(Ping-tと黒本と似た問題内容)
  

   (1)ネットワークメンテナンスモデル
   (2)GUI・CLI・リモートにSDMやTelnet等をD&D



 【3. トラブルチケット(12問)】

  このうち、バグ問題が2or3つつある。

   (1)IPv6(2問) ※インターフェースにOSPFの設定無い

   (2)HSRP2問) ※指定しているtrackを変更

   (3)クライアントからサーバにアクセス不可(8問)※切り分け問題

      ① BGP neighborのアドレスが異なる
      ② allowed vlan(access-list)が違う(Port13だがPort12を選択するバグの問題)
      ③ クライアントPC接続インターフェースがshutdown
      ④ OSPFの認証機能
      ⑤ EIGRP
      ⑥ 再配送不可(BGPからOSPF)
      ⑦ VACL
      ⑧ NTP問題
      ⑨ STP問題

     下記を回答する必要がある。

    ① どの機器か?
    ② どのテクノロジーを使うか?
    ③ どうすれば直るか?




■2. バグ問題情報(被疑箇所はスイッチ


 【1. 問題文のIF番号記載誤り】

   (対処方法) I/F番号の方は数字が違っていても気にせず選択、



 【2. コンフィグ表示不具合】

   (1)事象
     ① VACLに対する選択肢が見当たらない
     ② イーサチャネルのチャネル番号が一致しない

   ・show ip bgp summary コマンド結果が非表示(空白)
   ・show ip ospf neighbor コマンド結果が非表示(空白)
   ・show ip interface brief コマンド結果が非表示(空白)


   (2)対処方法

   両方ともネイバー(ピア)を張れていない際に発生しているが、
   動作としてはまるで表示されたかのようになっている。

   対向ルータにおいて、show ip ospf neighborコマンドでコンフィグを見ると、
   show ip route で存在すべき経路がないので、選択肢から正解を選ぶことが可能。

-

 【3. 「次へ」ボタンのリンク誤り】


  (1)事象
    
    問題回答時において、選択肢である「被疑機器」「関連技術」と選択を進めた後、
    関係ない技術のトラブル・シュート選択画面に飛ばされる


  (2)対処方法

   被疑機器の隣接機器の場合、正しい選択肢が表示される為、
   隣接機器を「被疑機器」として見立て選択し、正しい「関連技術」と「トラブル・シュート方法」の
   組み合わせを選択する。

   尚、隣接機器は複数存在し、どの隣接機器の画面においても同じ内容が表示されるが、
   通信経路上の方にある隣接機器を選択する。









FC2-Counter (Since 2013/8)